package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B\d{3}`)
var str = `123456`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}