$re = '/\d{3}(?=\d{2}(?!\d))/';
$str = 'number 123456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);