$re = '/^(?!\d+$)(?!(?:[^$&%@]*[$&%@]){4})(?!.*\b\w{11}).{3,}$/m';
$str = '1234
asdf
acv asdfghj 12345678901
acv asdfghj 1234567890
12
12d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);