$re = '/[A-Z]+\s([0-9]+)/m';
$str = 'ABCDE 11111 22222 FGHIJ 33333 KLMNO 44444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);