re = /(?s)".*?"(?<!\\.)/
str = '"10\\" 2 Topping Pizza, Pasta, or Sandwich for $5 each. Valid until 2pm. Carryout only.","blah blah"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end