package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:\.\w+)*|[^\w\s]`)
var str = `Mr.Smith is a professor at Harvard, and is a great guy.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}