$re = '/^(?=0)^.([6-9])|^(1)|^(?=2)^.([0-6])/m';
$str = '2600';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);