$re = '/\s*\[[^\]\s]*\]\s*/m';
$str = 'qwertyqwerty
qwerty[]qwerty
qwerty[qwerty]qwerty
qwerty[ ]qwerty
qwerty[qw erty]qwerty
qwerty[qwerty] qwerty
qwerty [qwerty]qwerty
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);