$re = '/\+?1?\D*\d\d\d\D*\d\d\d\D*\d\d\d\d\b/';
$str = 'http://www.website.com/MajorCategory/MinorCateory/118326/title-of-page.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);