using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\>\s*\{\{|\>\s*[a-zA-Z0-9]|\:\s*[\'|\""]";
string input = @"HTML plain strings
<a>zxc
<a> zxc
<a> 7xc
<a>
zxc
<a>
zxc
<a>
7xc
HTML strings evaluated by angular
<a>{{ 'asdasd
<a>{{'asdasd
<a> {{ 'asdasd
<a> {{'asdasd
<a>{{ ""asdasd
<a>{{""asdasd
<a> {{ ""asdasd
<a> {{""asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ 'asdasd
<a>
{{'asdasd
<a>
{{ ""asdasd
<a>
{{""asdasd
<a>
{{ ""asdasd
<a>
{{""asdasd
JS plain strings
asd: '
asd:'
asd: ""
asd:""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}