package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+\s[A-Za-z]+$d`)
var str = `FirstName MiddleName
FirstOnly
First Middle Last`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}