re = /(?:version\/|(?:msie|chrome|safari|firefox|opera) )([\d.]+)/im
str = 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1
Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0)
Opera/9.80 (Windows NT 6.0) Presto/2.12.388 Version/12.14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end