package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\r\\n\w*)|(\w+)`)
var str = `\r\ndsadasdsad\das\rdasdsacxz\ndasdsa\r\nadsadas\e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}