using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*([.,\/-\(\)]?\d+)";
string input = @"1
1.1
.1
1,1
,1
1/
11
111-22
1111";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}