package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\.\d+`)
var str = `123.22
2.2
87.1
123.123
3334
33355
1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}