package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\.|[^ \t\n<>&|])*`)
var str = `echo aaa>text.txt
echo aaa\>text.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}