using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<![\\])['""])((?:.(?!(?<![\\])\1))*.?)\1";
string input = @"[1, ""c"", ""[\""asd\"" , 2]""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}