$re = '/^[^ ]([^ ]| (?!.+ .+))+[^ ]$/m';
$str = 'http://localhost/e sculape/www/index.ph p?a=10
http://localhost/esculape/www/index.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);