$re = '/(?<=")[^"]+/';
$str = 'Test start. "Test match this". Test end.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);