$re = '/(.*)-(?:.*)-(?:.*)-(?:.*)/i';
$str = 'vendor-some-bundle-v1.0.0-XXXXXX.zip';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);