$re = '/^access-list\s+(.*?)\s+(remark|extended\s+.*?)$/';
$str = ' permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);