re = /See\s([A-Z' ]+)\W(\w+)\./
str = 'See ABC\'D EFG;IJKL.
'
subst = 'See:["$1","$2"]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result