use strict;
my $str = 'abc
def';
my $regex = qr/(?<=\S)$/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";