re = /(^[a-zA-Z][\w]*)\s+(\d+)\s?-\s?(\d+)?\s?\/?\s?(\d+|\*)?/
str = 'bytes 0-10/200'
# Print the match result
str.match(re) do |match|
puts match.to_s
end