package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]*)\d+([a-zA-Z]*)$`)
var str = `a1b2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}