$re = '/(\p{L}+)(\d+)/';
$str = 'April2016May2016June2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);