use strict;
my $str = 'AAACDDBBK';
my $regex = qr/(.).*\1/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";