$re = '/^(?=.*\p{Lu})(?=.*\p{Ll})(?=.*\d)/';
$str = 'a1jhj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);