re = /(^https?:\/\/)((www)?)(\.)([\da-z\.-]{2,62})(\.)([a-z]{2,24})$/
str = 'https://www.asna.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end