package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(trunk#\d+)[^{]*{.*{ *([^}]*?) *}.*$`)
var str = `
net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled
`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}