import Foundation
let pattern = ##"^net trunk\s+([^#]+#\d+)[^{]*{.*{ *([^}]*?) *}.*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled
net trunk chocolate-cream-silk#314 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 3.14.15.92 65.35.89.79 } lacp enabled
net trunk ed-is-the-standard-text-editor#237 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 101.100.105.116 116.101.120.116 } lacp enabled
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)