$re = '/\b\d{4}\b|(\w*\d\w*)/';
$str = 'hello12345 12345hello 123456789 12 red hello 1234 5678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);