import re
regex = re.compile(r"^\[(?<tnx_key>.*)_|-\w+\]", flags=re.MULTILINE)
test_str = ("[IDMS-TJ_TJG022092200005GN00017] 332950 311551 OK 2 [133369] 342 29 OK\n"
"[ZVKK_R1000001-235CDC24E191DBCE4906CCD0ND0000001] 498728 488378 OK 1 [133564] 509 9 OK\n"
"[PE_CZ_R19.6_2226500012123062] 342295 331477 OK 2 [133365] 353 49 OK\n"
"[BAFIROPC_R1.1_186951760] 289068 282128 OK 1 [133392] 295 5 OK\n"
"[GALILEO_R19.4_MTA_03FH220922110216] 394234 383672 OK 2 [133537] 405 11 OK\n"
"[DBINTERNET_R19.4_HU_RE02209223-06008] 187797 168329 OK 2 [133526] 201 7 OK\n"
"[IDMS_1-I0781_944e2c3cafc0487db56f6b8d3a6a6e231] 193581 178804 OK 2 [133576] 206 4 OK")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")