$re = '/ro{2,4}ar/m';
$str = 'The lion said roar rooar roooar roooooooar!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);