import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(st=([^& ]*)|)(.*c=([^& ]*)|)(.*t=([^& ]*)|)(.*k=([^& ]*)|) HTTP";
final String string = "st=expand&c=22&t=button&k=fun HTTP\n"
+ "c=22&t=button&k=fun HTTP\n"
+ "st=expand&c=22&t=party&k=fun HTTP\n"
+ "st=expand&c=22&k=fun HTTP\n"
+ "st=expand HTTP\n"
+ " HTTP";
final String subst = "\\2,\\4,\\6,\\8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}