using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-[0-9].*";
string input = @"samba-winbind-clients-3.6.23-14.el6_6.i686
ncurses-libs-5.7-3.20090208.el6.i686";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}