re = /^[\w\-\.]+@([\w-]+\.)+[\w-]{2,}$/m
str = 'corsec@kimiafarma.co.id
kangoedin@gmail.com
boss@id.abbott'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end