import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bhref=\\\"([^\\\"]*?)\\\")(?![^]*?href)";
final String string = " <div>\n"
+ " <a href=\"showthread.php?t=5239160\" id=\"thread_title_5239160\">программа для точного определения местоположения любого гаджета</a>\n"
+ " <span class=\"smallfont\" style=\"white-space:nowrap\">(<img class=\"inlineimg\" src=\"https://static.kharkovforum.com/images/misc/multipage.gif\" alt=\"перейти на страницу\" border=\"0\" /> <a href=\"showthread.php?t=5239160\">1</a> <a href=\"showthread.php?t=5239160&page=2\">2</a>)</span>\n"
+ " </div>\n\n"
+ " \n\n"
+ " <div class=\"smallfont\">\n"
+ " \n"
+ " \n"
+ " <span style=\"cursor:pointer\" onclick=\"window.open('member.php?u=502041', '_self')\">I-am</span>\n"
+ " \n"
+ " </div>\n\n"
+ " \n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}