$re = '/(\btotal\b)(?!.*\1)/';
$str = 'total abc total foo total anything here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);