re = /(?<![.!?])(\s«?)(Ich|Mich|Mir|Du|Dich|Dir|Er|Ihn|Ihm|Ihr|Es|Wir|Uns|Euch)\b/
str = '«Du, Du willst doch nur ...»
some more Text. «Du, Du willst doch nur ...»
«Blah, blah, blah», sagte Er, «Du, Du willst doch nur...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end