re = /(?<="%function )[^%]+(?=%")/
str = '"%function test%"
"%function test%","%function test%"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end