$re = '/"(?!(,|$|\w))/';
$str = '"3610212505","3610212505","Jack is 6\'2" tall"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);