re = /"\[(.+?):.*?\]"/
str = '["{apple}","{mango}","[apple: red]", "[apple: green]","{pear}" ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end