$re = '/(^.+?)(\[\d{1,}\]{1,})(\[.+\]$)/i';
$str = 'ReportTemplateGraphParameters[graph-wind-speed-correlation][0][y_id]
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);