#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[^#?]+\.([a-zA-Z0-9]+)(?:[?#].*)?$"
Local $sString = "http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs.css?p=preview#test.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")