$re = '/(::=|\s*\|\s*)/';
$str = '<ab>::=<cd> <ef>|<gh>
<ri>::=hello|nope|we|super';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);