$re = '/\b[A-Za-z]{1,2}-\d{1,2}(?!-)/';
$str = 'A-1
B-1
A-1-1-1
A-1-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);