# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(á)|(é)|(í)|(ó)|(ú)|(ů)|(ý)|(š)|(č)|(ř)|(ě)|(ž)|(á)|(é)|(í)|(ó)|(ě)|(ú)|(ů)|(ý)|(š)|(č)|(ř)|(ž)"
test_str = "ok, umím to udělat přes tři pravidla"
subst = "((\\1a)|(\\2e)|(\\3i)|(\\4o)|(\\5u)|(\\6u)|(\\7y)|(\\8s)|(\\9c)|(\\10r)|(\\11e)|(\\12z)|(\\13a)|(\\14e)|(\\15i)|(\\16o)|(\\17e)|(\\18u)|(\\19u)|(\\20y)|(\\21s)|(\\22c)|(\\23r)|(\\24z))"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.