import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z\\u00C0-\\u017F]+";
final String string = "############################\n"
+ "# World Cup 2014 Brazil\n\n"
+ "Group A | Brazil Croatia Mexico Cameroon\n"
+ "Group B | Spain Netherlands Chile Australia\n"
+ "Group C | Colombia Greece Côte d'Ivoire Japan\n"
+ "Group D | Uruguay Costa Rica England Italy\n"
+ "Group E | Switzerland Ecuador France Honduras\n"
+ "Group F | Argentina Bosnia-Herzegovina Iran Nigeria\n"
+ "Group G | Germany Portugal Ghana United States\n"
+ "Group H | Belgium Algeria Russia South Korea\n\n"
+ "Group A:\n\n"
+ "(1) Thu Jun/12 17:00 Brazil 3-1 Croatia @ Arena de São Paulo, São Paulo (UTC-3)\n"
+ " [Neymar 29' 71', Oscar 91', Marcelo 11' (o.g.)]\n\n"
+ "(2) Fri Jun/13 13:00 Mexico 1-0 Cameroon @ Estádio das Dunas, Natal (UTC-3)\n"
+ " [Oribe Peralta: 61']\n\n"
+ "(17) Tue Jun/17 16:00 Brazil 0-0 Mexico @ Estádio Castelão, Fortaleza (UTC-3)\n"
+ "(18) Wed Jun/18 18:00 Cameroon 0-4 Croatia @ Arena Amazônia, Manaus (UTC-4)\n"
+ " [-; Ivica Olić 11', Ivan Perišić 48', Mario Mandžukić 61' 73']\n\n"
+ "(33) Mon Jun/23 17:00 Cameroon 1-4 Brazil @ Estádio Nacional Mané Garrincha, Brasília (UTC-3)\n"
+ " [Joel Matip 26'; Neymar 17' 35', Fred 49', Fernandinho 84']\n"
+ "(34) Mon Jun/23 17:00 Croatia 1-3 Mexico @ Arena Pernambuco, Recife (UTC-3)\n"
+ " [Ivan Perišić 87'; Rafael Márquez 72', Andres Guardado 75', Javier Hernández 82']\n\n"
+ "Group B:\n\n"
+ "(3) Fri Jun/13 16:00 Spain 1-5 Netherlands @ Arena Fonte Nova, Salvador (UTC-3)\n"
+ " [Xabi Alonso 27' (pen.); Robin Van Persie 44' 72', Arjen Robben 53' 80', Stefan De Vrij 65']\n\n"
+ "(4) Fri Jun/13 18:00 Chile 3-1 Australia @ Arena Pantanal, Cuiabá (UTC-4)\n"
+ " [Alexis Sánchez 12', Jorge Valdívia 14', Jean Beausejour 92'; Cahill 35']\n\n"
+ "(19) Wed Jun/18 16:00 Spain 0-2 Chile @ Estádio do Maracanã, Rio de Janeiro (UTC-3)\n"
+ " [-; Eduardo Vargas 20', Charles Aránguiz 43']\n\n"
+ "(20) Wed Jun/18 13:00 Australia 2-3 Netherlands @ Estádio Beira-Rio, Porto Alegre (UTC-3)\n"
+ " [Tim Cahill 21', Mile Jedinak 54' (pen.); Arjen Robben 20', Robin Van Persie 58', Memphis Depay 68']\n\n"
+ "(35) Mon Jun/23 13:00 Australia 0-3 Spain @ Arena da Baixada, Curitiba (UTC-3)\n"
+ " [-; David Villa 36', Fernando Torres 69', Juan Mata 82']\n\n"
+ "(36) Mon Jun/23 13:00 Netherlands 2-0 Chile @ Arena de São Paulo, São Paulo (UTC-3)\n"
+ " [Leroy Fer 77', Memphis Depay 92']\n\n"
+ "Group C:\n\n"
+ "(5) Sat Jun/14 13:00 Colombia 3-0 Greece @ Estádio Mineirão, Belo Horizonte (UTC-3)\n"
+ " [Pablo Armero 5', Teofilo Gutiérrez 58', James Rodríguez 93']\n"
+ " \n"
+ "(6) Sat Jun/14 22:00 Côte d'Ivoire 2-1 Japan @ Arena Pernambuco, Recife (UTC-3)\n"
+ " [Wilfried Bony 64', Gervinho 66'; Keisuke Honda 16']\n\n"
+ "(21) Thu Jun/19 13:00 Colombia 2-1 Côte d'Ivoire @ Estádio Nacional Mané Garrincha, Brasília (UTC-3)\n"
+ " [James Rodríguez 64', Juan Quintero 70'; Gervinho 73']\n\n"
+ "(22) Thu Jun/19 19:00 Japan 0-0 Greece @ Estádio das Dunas, Natal (UTC-3)\n\n"
+ "(37) Tue Jun/24 16:00 Japan 1-4 Colombia @ Arena Pantanal, Cuiabá (UTC-4)\n"
+ " [Shinji Okazaki 46'; Juan Cuadrado 17' (pen.), Jackson Martínez 55' 82', James Rodríguez 90']\n\n"
+ "(38) Tue Jun/24 17:00 Greece 2-1 Côte d'Ivoire @ Estádio Castelão, Fortaleza (UTC-3)\n"
+ " [Andreas Samaris 42', Georgios Samaras 93' (pen.); Wilfried Bony 74']\n\n\n"
+ "Group D:\n\n"
+ "(7) Sat Jun/14 16:00 Uruguay 1-3 Costa Rica @ Estádio Castelão, Fortaleza (UTC-3)\n"
+ " [Edinson Cavani 24' (pen.); Joel Campbell 54', Oscar Duarte 57', Marcos Ureña 84']\n\n"
+ "(8) Sat Jun/14 18:00 England 1-2 Italy @ Arena Amazônia, Manaus (UTC-4)\n"
+ " [Daniel Sturridge 37'; Claudio Marchisio 35', Mario Balotelli 50']\n\n"
+ "(23) Thu Jun/19 16:00 Uruguay 2-1 England @ Arena de São Paulo, São Paulo (UTC-3)\n"
+ " [Luis Suárez 39' 85'; Wayne Rooney 75']\n\n"
+ "(24) Fri Jun/20 13:00 Italy 0-1 Costa Rica @ Arena Pernambuco, Recife (UTC-3)\n"
+ " [-; Bryan Ruiz 44']\n\n"
+ "(39) Tue Jun/24 13:00 Italy 0-1 Uruguay @ Estádio das Dunas, Natal (UTC-3)\n"
+ " [-; Diego Godín 81']\n"
+ " \n"
+ "(40) Tue Jun/24 13:00 Costa Rica 0-0 England @ Estádio Mineirão, Belo Horizonte (UTC-3)\n\n\n"
+ "Group E:\n\n"
+ "(9) Sun Jun/15 13:00 Switzerland 2-1 Ecuador @ Estádio Nacional Mané Garrincha, Brasília (UTC-3)\n"
+ " [Admir Mehmedi 48', Haris Seferović 93'; Enner Valencia 22']\n"
+ "(10) Sun Jun/15 16:00 France 3-0 Honduras @ Estádio Beira-Rio, Porto Alegre (UTC-3)\n"
+ " [Noel Valladares 48' (o.g.), Karim Benzema 45' (pen.) 72']\n\n\n"
+ "(25) Fri Jun/20 16:00 Switzerland 2-5 France @ Arena Fonte Nova, Salvador (UTC-3)\n"
+ " [Blerim Džemaili 81', Granit Xhaka 87'; Olivier Giroud 17', Blaise Matuidi 18', Mathieu Valbuena 40', Karim Benzema 67', Moussa Sissoko 73']\n"
+ "(26) Fri Jun/20 19:00 Honduras 1-2 Ecuador @ Arena da Baixada, Curitiba (UTC-3)\n"
+ " [Carlo Costly 31'; Enner Valencia 34' 65']\n"
+ "(41) Wed Jun/25 16:00 Honduras 0-3 Switzerland @ Arena Amazônia, Manaus (UTC-4)\n"
+ " [-; Xherdan Shaqiri 6' 31' 71']\n\n"
+ "(42) Wed Jun/25 17:00 Ecuador 0-0 France @ Estádio do Maracanã, Rio de Janeiro (UTC-3)\n\n\n"
+ "Group F:\n\n"
+ "(11) Sun Jun/15 19:00 Argentina 2-1 Bosnia-Herzegovina @ Estádio do Maracanã, Rio de Janeiro (UTC-3)\n"
+ " [Sead Kolašinac 3' (o.g.), Lionel Messi 65'; Vedad Ibišević 85']\n\n"
+ "(12) Mon Jun/16 16:00 Iran 0-0 Nigeria @ Arena da Baixada, Curitiba (UTC-3)\n\n"
+ "(27) Sat Jun/21 13:00 Argentina 1-0 Iran @ Estádio Mineirão, Belo Horizonte (UTC-3)\n"
+ " [Lionel Messi 90']\n\n"
+ "(28) Sat Jun/21 18:00 Nigeria 1-0 Bosnia-Herzegovina @ Arena Pantanal, Cuiabá (UTC-4)\n"
+ " [Peter Odemwingie 29']\n\n\n"
+ "(43) Wed Jun/25 13:00 Nigeria 2-3 Argentina @ Estádio Beira-Rio, Porto Alegre (UTC-3)\n"
+ " [Ahmed Musa 4' 47'; Lionel Messi 3' 46', Marcos Rojo 50']\n\n"
+ "(44) Wed Jun/25 13:00 Bosnia-Herzegovina 3-1 Iran @ Arena Fonte Nova, Salvador (UTC-3)\n"
+ " [Edin Džeko 23', Miralem Pjanić 59', Avdija Vršajević 83'; Reza Ghoochannejhad 82']\n\n"
+ "Group G:\n\n"
+ "(13) Mon Jun/16 13:00 Germany 4-0 Portugal @ Arena Fonte Nova, Salvador (UTC-3)\n"
+ " [Thomas Müller 12' (pen.) 46' 78', Mats Hummels 32']\n"
+ " \n"
+ "(14) Mon Jun/16 19:00 Ghana 1-2 United States @ Estádio das Dunas, Natal (UTC-3)\n"
+ " [André Ayew 82'; Clint Dempsey 1', John Brooks 86']\n\n"
+ "(29) Sat Jun/21 16:00 Germany 2-2 Ghana @ Estádio Castelão, Fortaleza (UTC-3)\n"
+ " [Mario Götze 51', Miroslav Klose 71'; André Ayew 54', Asamoah Gyan 63']\n\n"
+ "(30) Sun Jun/22 18:00 United States 2-2 Portugal @ Arena Amazônia, Manaus (UTC-4)\n"
+ " [Jermaine Jones 64', Clint Dempsey 81'; Nani 5', Varela 95']\n\n"
+ "(45) Thu Jun/26 13:00 United States 0-1 Germany @ Arena Pernambuco, Recife (UTC-3)\n"
+ " [-; Thomas Müller 55']\n\n"
+ "(46) Thu Jun/26 13:00 Portugal 2-1 Ghana @ Estádio Nacional Mané Garrincha, Brasília (UTC-3)\n"
+ " [John Boye 31' (o.g.), Cristiano Ronaldo 80'; Asamoah Gyan 57']\n\n"
+ "Group H:\n\n"
+ "(15) Tue Jun/17 13:00 Belgium 2-1 Algeria @ Estádio Mineirão, Belo Horizonte (UTC-3)\n"
+ " [Marouane Fellaini 70', Dries Mertens 80'; Sofiane Feghouli 25' (pen.)]\n"
+ "(16) Tue Jun/17 18:00 Russia 1-1 South Korea @ Arena Pantanal, Cuiabá (UTC-4)\n"
+ " [Alexander Kerzhakov 74'; Lee Keunho 68'] \n"
+ "(31) Sun Jun/22 13:00 Belgium 1-0 Russia @ Estádio do Maracanã, Rio de Janeiro (UTC-3)\n"
+ " [Divock Origi 88']\n\n"
+ "(32) Sun Jun/22 16:00 South Korea 2-4 Algeria @ Estádio Beira-Rio, Porto Alegre (UTC-3)\n"
+ " [Son Heung Min 50', Koo Jacheol 72'; Islam Slimani 26', Rafik Halliche 28', Abdelmoumene Djabou 38', Yacine Brahimi 62']\n\n"
+ "(47) Thu Jun/26 17:00 South Korea 0-1 Belgium @ Arena de São Paulo, São Paulo (UTC-3)\n"
+ " [-; Jan Vertonghen 78']\n\n"
+ "(48) Thu Jun/26 17:00 Algeria 1-1 Russia @ Arena da Baixada, Curitiba (UTC-3)\n"
+ " [Islam Slimani 60'; Alexander Kokorin 6']\n\n\n"
+ "######################\n"
+ "# Finals\n\n"
+ "# Round of 16\n\n"
+ "(49) Sat Jun/28 13:00 Brazil 1-1 (3-2 pen.) Chile @ Estádio Mineirão, Belo Horizonte (UTC-3) # 1A - 2B\n"
+ " [David Luiz 18'; Alexis Sánchez 32']\n\n"
+ "(50) Sat Jun/28 17:00 Colombia 2-0 Uruguay @ Estádio do Maracanã, Rio de Janeiro (UTC-3) # 1C - 2D\n"
+ " [James Rodríguez 28' 50']\n\n"
+ "(51) Sun Jun/29 13:00 Netherlands 2-1 Mexico @ Estádio Castelão, Fortaleza (UTC-3) # 1B - 2A \n"
+ " [Wesley Sneijder 88' Klaas Jan Huntelaar 90' (pen); Giovani dos Santos 48']\n"
+ " \n"
+ "(52) Sun Jun/29 17:00 Costa Rica 1-1 (5-3 pen.) Greece @ Arena Pernambuco, Recife (UTC-3) # 1D - 2C \n"
+ " [Bryan Ruiz 52'; Socratis Papastathopoulos 90']\n\n"
+ "(53) Mon Jun/30 13:00 France 2-0 Nigeria @ Estádio Nacional Mané Garrincha, Brasília (UTC-3) # 1E - 2F \n"
+ " [Paul Pogba 79', Joseph Yobo 92' (o.g.)]\n\n"
+ "(54) Mon Jun/30 17:00 Germany 2-1 Algeria @ Estádio Beira-Rio, Porto Alegre (UTC-3) # 1G - 2H\n"
+ " [André Schürrle 92', Mesut Özil 120'; Abdelmoumene Djabou 121']\n\n"
+ "(55) Tue Jul/1 13:00 Argentina 1-0 Switzerland @ Arena de São Paulo, São Paulo # 1F - 2E\n"
+ " [Ángel di María 118']\n"
+ " \n"
+ "(56) Tue Jul/1 17:00 Belgium 2-1 United States @ Arena Fonte Nova, Salvador # 1H - 2G \n"
+ " [Kevin De Bruyne 93', Romelu Lukaku 105'; Julian Green 107']\n\n\n\n"
+ "# Quarter-finals\n\n"
+ "(57) Fri Jul/4 17:00 Brazil 2-1 Colombia @ Estádio Castelão, Fortaleza # W49 - W50 \n"
+ " [Thiago Silva 7', David Luiz 69'; James Rodríguez 80' (pen.)]\n\n"
+ "(58) Fri Jul/4 13:00 France 0-1 Germany @ Estádio do Maracanã, Rio de Janeiro (UTC-3) # W53 - W54\n"
+ " [-; Mats Hummels 13']\n\n"
+ "(59) Sat Jul/5 17:00 Netherlands 0-0 (4-3 pen.) Costa Rica @ Arena Fonte Nova, Salvador (UTC-3) # W51 - W52 \n\n"
+ "(60) Sat Jul/5 13:00 Argentina 1-0 Belgium @ Estádio Nacional Mané Garrincha, Brasília (UTC-3) # W55 - W56 \n"
+ " [Gonzalo Higuaín 8']\n\n\n\n"
+ "# Semi-finals\n\n"
+ "(61) Tue Jul/8 17:00 Brazil 1-7 Germany @ Estádio Mineirão, Belo Horizonte (UTC-3) # W57 - W58\n"
+ " [Oscar 90'; Thomas Müller 11', Miroslav Klose 23', Toni Kroos 24' 26', Sami Khedira 29', Andre Schürrle 69' 79']\n\n"
+ "(62) Wed Jul/9 17:00 Netherlands 0-0 (2-4 pen.) Argentina @ Arena de São Paulo, São Paulo (UTC-3) # W59 - W69 \n\n\n\n"
+ "(19) Match for third place\n\n"
+ "(63) Sat Jul/12 17:00 Brazil 0-3 Netherlands @ Estádio Nacional Mané Garrincha, Brasília (UTC-3) # L61 - L62\n"
+ " [-; Robin Van Persie 3' (pen.), Daley Blind 17', Georginio Wijnaldum 91']\n\n\n"
+ "# Final\n\n"
+ "(64) Sun Jul/13 16:00 Germany 1-0 Argentina @ Estádio do Maracanã, Rio de Janeiro (UTC-3) # W61 - W62\n"
+ " [Mario Götze 113']\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}