re = /^\s*(?!.*::.*::)(?:(?!:)|:(?=:))(?:[0-9a-f]{0,4}(?:(?<=::)|(?<!::):)){6}(?:[0-9a-f]{0,4}(?:(?<=::)|(?<!::):)[0-9a-f]{0,4}(?:(?<=::)|(?<!:)|(?<=:)(?<!::):)|(?:25[0-4]|2[0-4]\d|1\d\d|[1-9]?\d)(?:\.(?:25[0-4]|2[0-4]\d|1\d\d|[1-9]?\d)){3})\s*$/im
str = '2001:4860:4860::8888
2001:db8::1234:5678:5.6.7.8
::11.22.33.44
fe80::210:a4ff:fee3:9566
2001:db8::1234:5678:5.6.7.8
[2001:4860:4860::8888]:80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end